Ubuntu es el mas Fuerte en PHP.!

Hace poco hice un pequeño sistema de inventario para un negocio de un familiar en PHP. Me costo un poco porque no sabia mucho de programación , especialmente en PHP pero como saben en el internet es una buenisima fuente de informacion

“No te da todo pero te dan las ideas como se debe pensar y como debe hacer las cosas”

Bueno finalmente lo termine y todooo me funciono de maravillas pero mis familiares lo querian funcionando en windows les dije q si…

Instale el xampp en windows como en linux

Despues hice las bases de datos “todo fue bien”

Pero cuando inicia el sistema me dio un montonazo de errores.! q no me dada en linux y dijo yo WTF MEN.!!! porque sera??!

Todavia no lo se estoy lo estoy investigando =( .!!

Unos de los errores eran:

1- session start(); parece que en windows solo funciona arriba del html y no tiene que haber espacios en blanco.  Ni idea??

2- ¿Warning: session_start() [function.session-start]: Cannot send session cookie – headers already sent by

Esto ya lo arregle pero no entiendo porque me da esto en windows y no en linux??

Bueno al final de todo voy a publicar posts ó tutoriales relacionado con:

Log In

-Registrar

-Pantalla Principal

– Un pequeño Inventario que todavia esta bajo contrucción“pero funciona”

Todo esta hecho usando PHP y un poco de Javascript.

Hasta la proxima linuxeros.!

Anuncios

4 Respuestas a “Ubuntu es el mas Fuerte en PHP.!

  1. no es que en linux no tenga errores, lo que puede pasar es que en linux no muestra los errores por la configuracion de php, intenta revisar el php.ini de linux en display_errors

    • Aqui esta amigo
      ; display_errors
      ; Default Value: On
      ; Development Value: On
      ; Production Value: Off

      ; display_startup_errors
      ; Default Value: Off
      ; Development Value: On
      ; Production Value: Off

      ; error_reporting
      ; Default Value: E_ALL & ~E_NOTICE
      ; Development Value: E_ALL | E_STRICT
      ; Production Value: E_ALL & ~E_DEPRECATED

      ; html_errors
      ; Default Value: On
      ; Development Value: On
      ; Production value: Off

      ; log_errors
      ; Default Value: Off
      ; Development Value: On
      ; Production Value: On

      Veo que todo esta bien

  2. sip es eso aparte de seguro instalaste la versión mas resiente de xamp en windows la cual contiene una la versión 5.3 de php, y trae un pedo con el soporte de <? ya no le gusta a php o lo cambias a <?php o mueres en el intento….. checa también la versión de php que instalaste en ubuntu….

    • Mmm… Creo q ahi no hay ningun pedo Sasuke

      Porque el xampp de Windows y Linux es de la misma version PHP Version 5.3.1
      Te lo Aseguro.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s